收藏官网首页
查看: 4914|回复: 3

[问答] 根据APICloud开源框架使用指南 操作出错

3

主题

9

帖子

146

积分

注册会员

Rank: 2

积分
146
发表于 2018-3-29 12:34:02 | 显示全部楼层 |阅读模式
汉枫LPB120模块

根据APICloud开源框架使用指南操作出错,一步一步按照指南的步骤流程操作,但是碰到以下的问题:


根据“引入GizWitsSKD”章节,移植源码与修改config.xml后将代码提交到云端,APICloudb并未自动导入相应的模块,不知道这里是哪里出了问题。
手动导入教程图示中的所有模块后,wifi同步测试还是不能扫码添加设备,提示“JavaScript Err”  TypeError: null is not an object (evaluating 'fNScanner.openView') at headers.html: 476

请问有谁碰到过这类问题吗,应该如何解决?






34

主题

896

帖子

2274

积分

超级版主

Rank: 8Rank: 8

积分
2274
发表于 2018-3-30 10:16:19 | 显示全部楼层
你是否少导入了一个扫描二维码的模块

点评

应该就是那个FNScanner吧,确定已经添加了的。  详情 回复 发表于 2018-3-30 17:15

3

主题

9

帖子

146

积分

注册会员

Rank: 2

积分
146
 楼主| 发表于 2018-3-30 17:15:30 | 显示全部楼层
boboP 发表于 2018-3-30 10:16
你是否少导入了一个扫描二维码的模块

C:\Users\cn-rd14\Desktop\modules.png
应该就是那个FNScanner吧,确定已经添加了的。

0

主题

3

帖子

96

积分

注册会员

Rank: 2

积分
96
发表于 2018-4-12 09:51:00 | 显示全部楼层
编译生成正式版看看了,另外机智云给的开源demo安卓貌似一直没有实现扫码添加设备,至少添加虚拟设备不行。。。
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

加入Q群 返回顶部

© 2011-2017 Gizwits ( 粤ICP备11090211号 )

快速回复 返回顶部 返回列表